Friday, May 17, 2013

AToM and VPLS

Virtual Private LAN Services (VPLS), is basically an extension to a AToM Feature, where in the AToM Feature you can only can emulate P2P interconnection using any technology, where this is the best part, while in the VPLS feature we can emulate the P2M Interconnection, but currently only limited to the Ethernet Technology.

The bad thing about the VPLS is that this technology is hardware related :(, so that is why, this feature is commonly deployed in the Big Routers. But Today I will show you guys how to deploy this two Technology Together using IOS-XR, yes I am fortunate enough to get hands on with the IOS-XR, lets get going






·         Configure AToM to Interconnect UPE11 & UPE13
·         Configure VPLS to Interconnect UPE31 & UPE32


Alright, we now entering the Interesting area here, which I will use IOS-XR to demonstrate the AToM and the VPLS Feature. As we know that the VPLS feature is very hardware specific, it can be done in both IOS or IOS-XR, but in the IOS, the supported platform is 7600 in the time of this writing. Ok let’s go to the scenario one by one

·         Configure AToM to Interconnect UPE11 & UPE13

Both AToM or VPLS in IOS-XR will use the same configuration fashion, where first off we need to define the L2Transport interface or the interface that will become a Attachment Circuit (AC) and then we specified the Targeted LDP inside the L2VPN configuration, which in my opinion is much more granular compare to the regular IOS ;)

NPE-XR1
!
interface GigabitEthernet0/0/0/1
 l2transport
 !
Commit
!
l2vpn
!
 pw-class PC_ETH11_TO_ETH13
  encapsulation mpls
  !
 !
 xconnect group GROUP_ATOM
  p2p L2CIRCUIT_TO_XR2
   interface GigabitEthernet0/0/0/1
   neighbor 2.2.2.2 pw-id 1113
    pw-class PC_ETH11_TO_ETH13
   !
  !
 !
Commit

NPE-XR2
!
interface GigabitEthernet0/0/0/1
 l2transport
 !
Commit
!
l2vpn
 !
 pw-class PC_ETH13_TO_ETH11
  encapsulation mpls
  !
 !
 xconnect group ATOM
  p2p L2CIRCUIT_TO_XR1
   interface GigabitEthernet0/0/0/1
   neighbor 1.1.1.1 pw-id 1113
    pw-class PC_ETH13_TO_ETH11
   !
  !
 !
commit

While in the Customer configuration, which are UPE-11 and UPE-13, the configuration will straight forward
UPE-11
!
interface Loopback0
 ip address 11.11.11.11 255.255.255.255
!
interface Vlan1
 ip address 192.168.1.11 255.255.255.0
!
router eigrp 1142
 network 0.0.0.0
 passive-interface FastEthernet0
!
End

UPE-13
!
interface Loopback0
 ip address 13.13.13.13 255.255.255.255
!
interface Vlan1
 ip address 192.168.1.13 255.255.255.0
!
router eigrp 1142
 network 0.0.0.0
 passive-interface FastEthernet0
!
end

Now, take a look closer to the configuration on both NPE-XR1 and NPE-XR2. NPE-XR1/NPE-XR2 will create an additional MPLS Transport Label for the AToM Interconnection using Circuit Number 1113.
RP/0/RSP1/CPU0:NPE-XR1#show mpls ldp neighbor
Tue Mar 26 05:42:51.902 UTC

<..SNIP…>

Peer LDP Identifier: 2.2.2.2:0
  TCP connection: 2.2.2.2:29265 - 1.1.1.1:646
  Graceful Restart: No
  Session Holdtime: 180 sec
  State: Oper; Msgs sent/rcvd: 51/51; Downstream-Unsolicited
  Up time: 00:31:27
  LDP Discovery Sources:
    Targeted Hello (1.1.1.1 -> 2.2.2.2, active)
  Addresses bound to this peer:
    2.2.2.2          10.0.8.7         20.2.4.2     

RP/0/RSP1/CPU0:NPE-XR1#show mpls forwarding
Tue Mar 26 05:42:58.261 UTC
Local  Outgoing    Prefix             Outgoing     Next Hop        Bytes      
Label  Label       or ID              Interface                    Switched   
------ ----------- ------------------ ------------ --------------- ------------
16000  Pop         PW(2.2.2.2:1113)   Gi0/0/0/1    point2point     311310     
16011  Pop         3.3.3.3/32         Te0/1/0/0    20.1.3.3        7407       
16012  Unlabelled  20.3.4.0/24        Te0/1/0/0    20.1.3.3        0          
16013  3000        4.4.4.4/32         Te0/1/0/0    20.1.3.3        2768       
16014  Unlabelled  20.2.4.0/24        Te0/1/0/0    20.1.3.3        0          
16015  3002        2.2.2.2/32         Te0/1/0/0    20.1.3.3        300118     

RP/0/RSP1/CPU0:NPE-XR1#show l2vpn xconnect brief  
Tue Mar 26 05:43:30.188 UTC
AToM
  Like-to-Like                        UP       DOWN        UNR
    Ether                              1          0          0
    Total                              1          0          0

  Total                                1          0          0

Total: 1 UP, 0 DOWN, 0 UNRESOLVED

RP/0/RSP1/CPU0:NPE-XR1#show l2vpn xconnect interface g0/0/0/1
Tue Mar 26 05:43:50.460 UTC
Legend: ST = State, UP = Up, DN = Down, AD = Admin Down, UR = Unresolved,
        SB = Standby, SR = Standby Ready, (PP) = Partially Programmed

XConnect                   Segment 1                       Segment 2               
Group      Name       ST   Description            ST       Description            ST   
------------------------   -----------------------------   -----------------------------
GROUP_ATOM L2CIRCUIT_TO_XR2
                      UP   Gi0/0/0/1              UP       2.2.2.2         1113   UP   
----------------------------------------------------------------------------------------

RP/0/RSP1/CPU0:NPE-XR1#show l2vpn xconnect summary
Tue Mar 26 05:43:23.953 UTC
Number of groups: 1
Number of xconnects: 1
  Up: 1  Down: 0  Unresolved: 0 Partially-programmed: 0
  AC-PW: 1  AC-AC: 0  PW-PW: 0 Monitor-Session-PW: 0
Number of Admin Down segments: 0
Number of MP2MP xconnects: 0
  Up 0 Down 0
  Advertised: 0 Non-Advertised: 0
Number of CE Connections: 0
  Advertised: 0 Non-Advertised: 0
Backup PW:
  Configured   : 0
  UP           : 0
  Down         : 0
  Admin Down   : 0
  Unresolved   : 0
  Standby      : 0
  Standby Ready: 0
Backup Interface:
  Configured   : 0
  UP           : 0
  Down         : 0
  Admin Down   : 0
  Unresolved   : 0
  Standby      : 0

RP/0/RSP1/CPU0:NPE-XR1#show l2vpn xconnect detail
Tue Mar 26 05:44:12.208 UTC

Group GROUP_ATOM, XC L2CIRCUIT_TO_XR2, state is up; Interworking none
  AC: GigabitEthernet0/0/0/1, state is up
    Type Ethernet
    MTU 1500; XC ID 0x40004; interworking none
    Statistics:
      packets: received 1192, sent 1800
      bytes: received 251953, sent 323564
  PW: neighbor 2.2.2.2, PW ID 1113, state is up ( established )
    PW class PC_ETH11_TO_ETH13, XC ID 0xc0000001
    Encapsulation MPLS, protocol LDP
    Source address 1.1.1.1
    PW type Ethernet, control word disabled, interworking none
    PW backup disable delay 0 sec
    Sequencing not set

    PW Status TLV in use
      MPLS         Local                          Remote                       
      ------------ ------------------------------ -----------------------------
      Label        16000                          20005                        
      Group ID     0x100                          0x4000100                    
      Interface    GigabitEthernet0/0/0/1         GigabitEthernet0/0/0/1       
      MTU          1500                           1500                          
      Control word disabled                       disabled                     
      PW type      Ethernet                       Ethernet                     
      VCCV CV type 0x2                            0x2                           
                   (LSP ping verification)        (LSP ping verification)      
      VCCV CC type 0x6                            0x6                          
                   (router alert label)           (router alert label)         
                   (TTL expiry)                   (TTL expiry)                 
      ------------ ------------------------------ -----------------------------
    Incoming Status (PW Status TLV):
      Status code: 0x0 (Up) in Notification message
    Outgoing Status (PW Status TLV):
      Status code: 0x0 (Up) in Notification message
    MIB cpwVcIndex: 3221225473
    Create time: 26/03/2013 05:09:06 (00:35:05 ago)
    Last time status changed: 26/03/2013 05:11:24 (00:32:46 ago)
    Statistics:
      packets: received 1800, sent 1192
      bytes: received 323564, sent 251953


RP/0/RSP0/CPU0:NPE-XR2#show mpls ldp neighbor 1.1.1.1
Mon Mar 25 20:19:21.750 UTC

Peer LDP Identifier: 1.1.1.1:0
  TCP connection: 1.1.1.1:646 - 2.2.2.2:29265
  Graceful Restart: No
  Session Holdtime: 180 sec
  State: Oper; Msgs sent/rcvd: 79/79; Downstream-Unsolicited
  Up time: 00:56:09
  LDP Discovery Sources:
    Targeted Hello (2.2.2.2 -> 1.1.1.1, active)
  Addresses bound to this peer:
    1.1.1.1          10.0.8.6         20.1.3.1        

RP/0/RSP0/CPU0:NPE-XR2#show mpls forwarding
Mon Mar 25 20:19:35.445 UTC
Local  Outgoing    Prefix             Outgoing     Next Hop        Bytes      
Label  Label       or ID              Interface                    Switched    
------ ----------- ------------------ ------------ --------------- ------------
20000  Pop         4.4.4.4/32         Te0/1/0/0    20.2.4.4        9898       
20001  Pop         20.3.4.0/24        Te0/1/0/0    20.2.4.4        0          
20002  4000        3.3.3.3/32         Te0/1/0/0    20.2.4.4        0          
20003  4002        1.1.1.1/32         Te0/1/0/0    20.2.4.4        914189     
20004  4001        20.1.3.0/24        Te0/1/0/0    20.2.4.4        0          
20005  Pop         PW(1.1.1.1:1113)   Gi0/0/0/1    point2point     330634

RP/0/RSP0/CPU0:NPE-XR2#show l2vpn xconnect detail           
Mon Mar 25 19:57:55.748 UTC

Group ATOM, XC L2CIRCUIT_TO_XR1, state is up; Interworking none
  AC: GigabitEthernet0/0/0/1, state is up
    Type Ethernet
    MTU 1500; XC ID 0x840003; interworking none
    Statistics:
      packets: received 2334, sent 894
      bytes: received 417824, sent 204466
  PW: neighbor 1.1.1.1, PW ID 1113, state is up ( established )
    PW class PC_ETH13_TO_ETH11, XC ID 0xc0000001
    Encapsulation MPLS, protocol LDP
    Source address 2.2.2.2
    PW type Ethernet, control word disabled, interworking none
    PW backup disable delay 0 sec
    Sequencing not set

    PW Status TLV in use
      MPLS         Local                          Remote                       
      ------------ ------------------------------ -----------------------------
      Label        20005                          16000                        
      Group ID     0x4000100                      0x100                        
      Interface    GigabitEthernet0/0/0/1         GigabitEthernet0/0/0/1       
      MTU          1500                           1500                         
      Control word disabled                       disabled                     
      PW type      Ethernet                       Ethernet                     
      VCCV CV type 0x2                            0x2                          
                   (LSP ping verification)        (LSP ping verification)      
      VCCV CC type 0x6                            0x6                          
                   (router alert label)           (router alert label)         
                   (TTL expiry)                   (TTL expiry)                 
      ------------ ------------------------------ -----------------------------
    Incoming Status (PW Status TLV):
      Status code: 0x0 (Up) in Notification message
    Outgoing Status (PW Status TLV):
      Status code: 0x0 (Up) in Notification message
    MIB cpwVcIndex: 3221225473
    Create time: 25/03/2013 19:23:12 (00:34:42 ago)
    Last time status changed: 25/03/2013 19:23:12 (00:34:42 ago)
    Statistics:
      packets: received 894, sent 2334
      bytes: received 204466, sent 417824     

On the Customer Side, we can see that the UPE-11 and UPE-13 will form an EIGRP adjacency
UPE-11#show  ip eigrp neighbors
EIGRP-IPv4 Neighbors for AS(1142)
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   192.168.1.13            Vl1               14 01:03:37   10   200  0  7

EIGRP-IPv4 Neighbors for AS(1142)
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
1   192.168.1.11            Vl1               11 01:03:45    9   200  0  15


·         Configure VPLS to Interconnect UPE31 & UPE32

AToM is cool, where we can interconnect different L2 technologies, but it is limited to the fact that its Point-to-point connection. While in the Virtual Private LAN Service / VPLS we can do have point-to-multipoint interconnection but it only limited to the Ethernet Technology, currently ant the time of this writing.

The configuration is quite different from the AToM, where in the VPLS we have to define the Virtual Forwarding Instance, and each of the PE should maintain the MAC-Address table from the customer on its CAM.

NPE-XR1
!
interface TenGigE0/1/0/3
 description UPE-31
 mtu 9216
 l2transport
 !
!
Commit
!
l2vpn
 pw-class PC_VPLS
  encapsulation mpls
   transport-mode ethernet
  !
 !
  !
 !
 bridge group BG_VPLS
  bridge-domain BD_VPLS1
   interface TenGigE0/1/0/3
   !
   vfi VFI_TO_XR2
    neighbor 2.2.2.2 pw-id 3132
     pw-class PC_VPLS
    !
   !
  !
 !
!
commit
NPE-XR2
!
interface TenGigE0/1/0/3
 description UPE-32
 l2transport
 !
!
Commit
!
l2vpn
 pw-class PC_VPLS
  encapsulation mpls
   transport-mode ethernet
  !
 !
  !
 !
 bridge group BG_VPLS
  bridge-domain BD_VPLS1
   interface TenGigE0/1/0/3
   !
   neighbor 1.1.1.1 pw-id 3132
    pw-class PC_VPLS
   !
  !
 !
!
commit

Note that I do the following on purpose
·         The MTU interface that facing to the UPE-31 on the NPE-XR1 is larger than the MTU that facing to the UPE-32 on the NPE-XR2
·         I didn’t use the VFI on the NPE-XR2, while on the NPE-XR1 I used it

While the configuration on the Customer side is obvious
UPE-31
!
interface Loopback0
 ip address 31.31.31.31 255.255.255.255
!
interface Vlan1
 ip address 10.0.0.31 255.255.255.0
!
router ospf 1
 passive-interface GigabitEthernet0
 network 0.0.0.0 255.255.255.255 area 0
!
end
UPE-32
!
interface Loopback0
 ip address 32.32.32.32 255.255.255.255
!
interface Vlan1
 ip address 10.0.0.32 255.255.255.0
!
router ospf 1
 passive-interface GigabitEthernet0
 network 0.0.0.0 255.255.255.255 area 0
!
end

Ok, let’s take a look into the verification on NPE-XR1 here
RP/0/RSP1/CPU0:NPE-XR1#show l2vpn bridge-domain brief
Tue Mar 26 05:44:22.682 UTC
Legend: pp = Partially Programmed.
Bridge Group:Bridge-Domain Name  ID    State          Num ACs/up   Num PWs/up
-------------------------------- ----- -------------- ------------ -------------
BG_VPLS:BD_VPLS1                 0     up             1/1          1/1         

RP/0/RSP1/CPU0:NPE-XR1#show l2vpn bridge-domain summary
Tue Mar 26 05:44:29.901 UTC
Number of groups: 1, bridge-domains: 1, Up: 1, Shutdown: 0, Partially-
programmed: 0
Default: 1, pbb-edge: 0, pbb-core: 0
Number of ACs: 1 Up: 1, Down: 0, Partially-programmed: 0
Number of PWs: 1 Up: 1, Down: 0, Standby: 0, Partially-programmed: 0

RP/0/RSP1/CPU0:NPE-XR1#show l2vpn bridge-domain interface teng0/1/0/3
Tue Mar 26 05:44:40.858 UTC
Legend: pp = Partially Programmed.
Bridge group: BG_VPLS, bridge-domain: BD_VPLS1, id: 0, state: up, ShgId: 0, MSTi: 0
  Aging: 300 s, MAC limit: 4000, Action: none, Notification: syslog
  Filter MAC addresses: 0
  ACs: 1 (1 up), VFIs: 1, PWs: 1 (1 up), PBBs: 0 (0 up)
  List of ACs:
    Te0/1/0/3, state: up, Static MAC addresses: 0

RP/0/RSP1/CPU0:NPE-XR1#show l2vpn bridge-domain detail              
Tue Mar 26 05:44:53.209 UTC
Legend: pp = Partially Programmed.
Bridge group: BG_VPLS, bridge-domain: BD_VPLS1, id: 0, state: up, ShgId: 0, MSTi: 0
  Coupled state: disabled
  MAC learning: enabled
  MAC withdraw: enabled
    MAC withdraw for Access PW: enabled
    MAC withdraw sent on bridge port down: disabled
  Flooding:
    Broadcast & Multicast: enabled
    Unknown unicast: enabled
  MAC aging time: 300 s, Type: inactivity
  MAC limit: 4000, Action: none, Notification: syslog
  MAC limit reached: no
  MAC port down flush: enabled
  MAC Secure: disabled, Logging: disabled
  Split Horizon Group: none
  Dynamic ARP Inspection: disabled, Logging: disabled
  IP Source Guard: disabled, Logging: disabled
  DHCPv4 snooping: disabled
  IGMP Snooping profile: none
  Bridge MTU: 1500
  MIB cvplsConfigIndex: 1
  Filter MAC addresses:
  Create time: 26/03/2013 05:25:46 (00:19:06 ago)
  No status change since creation
  ACs: 1 (1 up), VFIs: 1, PWs: 1 (1 up), PBBs: 0 (0 up)
  List of ACs:
    AC: TenGigE0/1/0/3, state is up
      Type Ethernet
      MTU 9202; XC ID 0x440001; interworking none
      MAC learning: enabled
      Flooding:
        Broadcast & Multicast: enabled
        Unknown unicast: enabled
      MAC aging time: 300 s, Type: inactivity
      MAC limit: 4000, Action: none, Notification: syslog
      MAC limit reached: no
      MAC port down flush: enabled
      MAC Secure: disabled, Logging: disabled
      Split Horizon Group: none
      Dynamic ARP Inspection: disabled, Logging: disabled
      IP Source Guard: disabled, Logging: disabled
      DHCPv4 snooping: disabled
      IGMP Snooping profile: none
      Storm Control: disabled
      Static MAC addresses:
      Statistics:
        packets: received 2388, sent 1762
        bytes: received 483060, sent 286345
      Storm control drop counters:
        packets: broadcast 0, multicast 0, unknown unicast 0
        bytes: broadcast 0, multicast 0, unknown unicast 0
      Dynamic ARP inspection drop counters:
        packets: 0, bytes: 0
      IP source guard drop counters:
        packets: 0, bytes: 0
  List of Access PWs:
  List of VFIs:
    VFI VFI_TO_XR2 (up)
      PW: neighbor 2.2.2.2, PW ID 3132, state is up ( established )
        PW class PC_VPLS, XC ID 0xc0000002
        Encapsulation MPLS, protocol LDP
        Source address 1.1.1.1
        PW type Ethernet, control word disabled, interworking none
        PW backup disable delay 0 sec
        Sequencing not set

        PW Status TLV in use
          MPLS         Local                          Remote                        
          ------------ ------------------------------ -------------------------
          Label        16001                          20006                        
          Group ID     0x0                            0x0                           
          Interface    VFI_TO_XR2                     Access PW                    
          MTU          1500                           1500                         
          Control word disabled                       disabled                      
          PW type      Ethernet                       Ethernet                     
          VCCV CV type 0x2                            0x2                          
                       (LSP ping verification)        (LSP ping verification)      
          VCCV CC type 0x6                            0x6                          
                       (router alert label)           (router alert label)         
                       (TTL expiry)                   (TTL expiry)                 
          ------------ ------------------------------ -------------------------
        Incoming Status (PW Status TLV):
          Status code: 0x0 (Up) in Notification message
        MIB cpwVcIndex: 3221225474
        Create time: 26/03/2013 05:40:23 (00:04:29 ago)
        Last time status changed: 26/03/2013 05:40:23 (00:04:29 ago)
        MAC withdraw message: send 0 receive 0
        Static MAC addresses:
        Statistics:
          packets: received 227, sent 97
          bytes: received 35113, sent 27279
      DHCPv4 snooping: disabled
      IGMP Snooping profile: none
      VFI Statistics:
        drops: illegal VLAN 0, illegal length 0

RP/0/RSP1/CPU0:NPE-XR1#show mpls forwarding
Tue Mar 26 06:23:20.716 UTC
Local  Outgoing    Prefix             Outgoing     Next Hop        Bytes      
Label  Label       or ID              Interface                    Switched   
------ ----------- ------------------ ------------ --------------- ------------
16000  Pop         PW(2.2.2.2:1113)   Gi0/0/0/1    point2point     707971     
16001  Pop         PW(2.2.2.2:3132)   BD=0         point2point     342957     
16011  Pop         3.3.3.3/32         Te0/1/0/0    20.1.3.3        11893      
16012  Unlabelled  20.3.4.0/24        Te0/1/0/0    20.1.3.3        0           
16013  3000        4.4.4.4/32         Te0/1/0/0    20.1.3.3        2768       
16014  Unlabelled  20.2.4.0/24        Te0/1/0/0    20.1.3.3        0          
16015  3002        2.2.2.2/32         Te0/1/0/0    20.1.3.3        800148     

Here are the verification on the NPE-XR2
RP/0/RSP0/CPU0:NPE-XR2#show l2vpn bridge-domain summary
Mon Mar 25 19:58:10.015 UTC
Number of groups: 1, bridge-domains: 1, Up: 1, Shutdown: 0, Partially-
programmed: 0
Default: 1, pbb-edge: 0, pbb-core: 0
Number of ACs: 1 Up: 1, Down: 0, Partially-programmed: 0
Number of PWs: 1 Up: 1, Down: 0, Standby: 0, Partially-programmed: 0
RP/0/RSP0/CPU0:NPE-XR2#
RP/0/RSP0/CPU0:NPE-XR2#show l2vpn bridge-domain brief  
Mon Mar 25 19:58:16.658 UTC
Legend: pp = Partially Programmed.
Bridge Group:Bridge-Domain Name  ID    State          Num ACs/up   Num PWs/up
-------------------------------- ----- -------------- ------------ -------------
BG_VPLS:BD_VPLS1                 0     up             1/1          1/1         

RP/0/RSP0/CPU0:NPE-XR2#show l2vpn bridge-domain interface teng0/1/0/3
Mon Mar 25 19:58:25.344 UTC
Legend: pp = Partially Programmed.
Bridge group: BG_VPLS, bridge-domain: BD_VPLS1, id: 0, state: up, ShgId: 0, MSTi: 0
  Aging: 300 s, MAC limit: 4000, Action: none, Notification: syslog
  Filter MAC addresses: 0
  ACs: 1 (1 up), VFIs: 0, PWs: 1 (1 up), PBBs: 0 (0 up)
  List of ACs:
    Te0/1/0/3, state: up, Static MAC addresses: 0

RP/0/RSP0/CPU0:NPE-XR2#show l2vpn bridge-domain detail              
Mon Mar 25 19:58:42.810 UTC
Legend: pp = Partially Programmed.
Bridge group: BG_VPLS, bridge-domain: BD_VPLS1, id: 0, state: up, ShgId: 0, MSTi: 0
  Coupled state: disabled
  MAC learning: enabled
  MAC withdraw: enabled
    MAC withdraw for Access PW: enabled
    MAC withdraw sent on bridge port down: disabled
  Flooding:
    Broadcast & Multicast: enabled
    Unknown unicast: enabled
  MAC aging time: 300 s, Type: inactivity
  MAC limit: 4000, Action: none, Notification: syslog
  MAC limit reached: no
  MAC port down flush: enabled
  MAC Secure: disabled, Logging: disabled
  Split Horizon Group: none
  Dynamic ARP Inspection: disabled, Logging: disabled
  IP Source Guard: disabled, Logging: disabled
  DHCPv4 snooping: disabled
  IGMP Snooping profile: none
  Bridge MTU: 1500
  MIB cvplsConfigIndex: 1
  Filter MAC addresses:
  Create time: 25/03/2013 19:39:17 (00:19:25 ago)
  No status change since creation
  ACs: 1 (1 up), VFIs: 0, PWs: 1 (1 up), PBBs: 0 (0 up)
  List of ACs:
    AC: TenGigE0/1/0/3, state is up
      Type Ethernet
      MTU 1500; XC ID 0xc40001; interworking none
      MAC learning: enabled
      Flooding:
        Broadcast & Multicast: enabled
        Unknown unicast: enabled
      MAC aging time: 300 s, Type: inactivity
      MAC limit: 4000, Action: none, Notification: syslog
      MAC limit reached: no
      MAC port down flush: enabled
      MAC Secure: disabled, Logging: disabled
      Split Horizon Group: none
      Dynamic ARP Inspection: disabled, Logging: disabled
      IP Source Guard: disabled, Logging: disabled
      DHCPv4 snooping: disabled
      IGMP Snooping profile: none
      Storm Control: disabled
      Static MAC addresses:
      Statistics:
        packets: received 3090, sent 1331
        bytes: received 539521, sent 272523
      Storm control drop counters:
        packets: broadcast 0, multicast 0, unknown unicast 0
        bytes: broadcast 0, multicast 0, unknown unicast 0
      Dynamic ARP inspection drop counters:
        packets: 0, bytes: 0
      IP source guard drop counters:
        packets: 0, bytes: 0
  List of Access PWs:
    PW: neighbor 1.1.1.1, PW ID 3132, state is up ( established )
      PW class PC_VPLS, XC ID 0xc0000002
      Encapsulation MPLS, protocol LDP
      Source address 2.2.2.2
      PW type Ethernet, control word disabled, interworking none
      PW backup disable delay 0 sec
      Sequencing not set

      PW Status TLV in use
        MPLS         Local                          Remote                       
        ------------ ------------------------------ ---------------------------
        Label        20006                          16001                        
        Group ID     0x0                            0x0                          
        Interface    Access PW                      VFI_TO_XR2                   
        MTU          1500                           1500                         
        Control word disabled                       disabled                     
        PW type      Ethernet                       Ethernet                     
        VCCV CV type 0x2                            0x2                          
                     (LSP ping verification)        (LSP ping verification)      
        VCCV CC type 0x6                            0x6                          
                     (router alert label)           (router alert label)         
                     (TTL expiry)                   (TTL expiry)                 
        ------------ ------------------------------ ---------------------------
      Incoming Status (PW Status TLV):
        Status code: 0x0 (Up) in Notification message
      MIB cpwVcIndex: 3221225474
      Create time: 25/03/2013 19:39:17 (00:19:25 ago)
      Last time status changed: 25/03/2013 19:52:11 (00:06:31 ago)
      MAC withdraw message: send 1 receive 0
      Static MAC addresses:
      Statistics:
        packets: received 395, sent 957
        bytes: received 114344, sent 149000
      Storm control drop counters:
        packets: broadcast 0, multicast 0, unknown unicast 0
        bytes: broadcast 0, multicast 0, unknown unicast 0
      MAC learning: enabled
      Flooding:
        Broadcast & Multicast: enabled
        Unknown unicast: enabled
      MAC aging time: 300 s, Type: inactivity
      MAC limit: 4000, Action: none, Notification: syslog
      MAC limit reached: no
      MAC port down flush: enabled
      MAC Secure: disabled, Logging: disabled
      Split Horizon Group: none
      DHCPv4 snooping: disabled
      IGMP Snooping profile: none
      Storm Control: disabled
  List of VFIs:

RP/0/RSP0/CPU0:NPE-XR2#show mpls forwarding
Mon Mar 25 20:36:46.511 UTC
Local  Outgoing    Prefix             Outgoing     Next Hop        Bytes      
Label  Label       or ID              Interface                    Switched   
------ ----------- ------------------ ------------ --------------- ------------
20000  Pop         4.4.4.4/32         Te0/1/0/0    20.2.4.4        11800      
20001  Pop         20.3.4.0/24        Te0/1/0/0    20.2.4.4        0          
20002  4000        3.3.3.3/32         Te0/1/0/0    20.2.4.4        0          
20003  4002        1.1.1.1/32         Te0/1/0/0    20.2.4.4        1229545    
20004  4001        20.1.3.0/24        Te0/1/0/0    20.2.4.4        0          
20005  Pop         PW(1.1.1.1:1113)   Gi0/0/0/1    point2point     430640     
20006  Pop         PW(1.1.1.1:3132)   BD=0         point2point     346714     

Based on the verification above, it seems that the IOS-XR automatically decrease the MTU that facing to the Customer Interface to be 1500. and also eventhough I didn’t specify the VFI on the NPE-XR2, it seems that the VPLS adjacency between NPE-XR1 and NPE-XR2 still become UP ;)

Ok, now we expect that the Customer, UPE-31 & UPE-32, will having the OSPF adjacency established
UPE-31#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
10.0.8.162        1   FULL/DR         00:00:31    10.0.0.32       Vlan1

UPE-32#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
31.31.31.31       1   FULL/BDR        00:00:36    10.0.0.31       Vlan1

well In this example, I only emulate two routers that connect to the VPLS, due to the Lab hardware limitation, in term of Device Quantity, but if we add additional device on the CE side, it is obvious that this new Device will eventually reside on the same Broadcast Domain ;)

well I hope this have been informative, and I'd like to thank you for reading ;)
 

1 comment:

engzizou said...

Thank you for the post
really helpful for exercising
ATOM and VPLS configs